Romsat forum
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.

Войти
Romsat forum
Страниц: 1 ... 7 8 [9] 10
 81 
 : Август 19, 2015, 17:17:32  
Автор DAnEq - Последний ответ от DAnEq
по поводу traffic segmentation

если мне надо блокировать траффик между портами с 1 по 24, правильно ли это делать так:
Код:
traffic-segmentation
traffic-segmentation uplink-to-uplink forwarding
traffic-segmentation session 1 uplink ethernet 1/25-28 downlink ethernet 1/1-24

?

 82 
 : Август 19, 2015, 12:31:18  
Автор DAnEq - Последний ответ от DAnEq
Код:
snmpset -c BluewaterRd29200 -v 2c 192.168.222.37 .1.3.6.1.4.1.259.6.10.94.1.24.1.1 i 2
Error in packet.
Reason: notWritable (That object does not support modification)
Failed object: SNMPv2-SMI::enterprises.259.6.10.94.1.24.1.1

конфиг
Код:
#sh ru
building running-config, please wait...
!<stackingDB>00</stackingDB>

hostname sw-252

sntp server 10.10.20.1 0.0.0.0 0.0.0.0
!
clock timezone UTC hour 2 minute 0 after-utc
!
prompt Malibu
snmp-server location Malibu,CA,90264
!
clock timezone-predefined GMT+0200-Helsinki,Kyiv,Riga,Sofia,Tallinn,Vilnius
!
snmp-server community BirdviewAve7100 ro
snmp-server community BluewaterRd29200 rw
!
username admin access-level 15
username admin password 7 8ee662ce4ac345e5022119851a1af82b
username guest access-level 0
username guest password 7 084e0343a0486ff05530df6c705c8bb4
enable password level 15 7 8ee662ce4ac345e5022119851a1af82b
!
logging facility 22
logging host 192.168.222.1
!
vlan database
 vlan 1 name DefaultVlan media ethernet state active
 vlan 100 name mgmt media ethernet state active
 private-vlan 500 primary
!
spanning-tree mst configuration
!
ip dhcp snooping
ip dhcp snooping vlan 500
ip dhcp snooping information option
ip dhcp snooping information option remote-id ip-address encode hex
!
no lldp
!
interface vlan 1
 ip dhcp client class-id text 1
interface vlan 100
 ip address 192.168.222.37 255.255.255.0
interface vlan 500
!
interface ethernet 1/1
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/2
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/3
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/4
 no switchport broadcast
 rate-limit input 10240
 rate-limit output 6144
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/5
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/6
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/7
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/8
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/9
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/10
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/11
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/12
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/13
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/14
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/15
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/16
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/17
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/18
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/19
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/20
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/21
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/22
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/23
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/24
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/25
 ip dhcp snooping trust
 switchport mode private-vlan promiscuous
 switchport allowed vlan add 100 tagged
!
interface ethernet 1/26
 ip dhcp snooping trust
 switchport mode private-vlan host
 switchport allowed vlan add 100 tagged
!
interface ethernet 1/27
!
interface ethernet 1/28
!
management telnet-client 10.10.20.1 10.10.20.15
management telnet-client 192.168.222.1 192.168.222.1
!
ip name-server 192.168.2.254
!
no spanning-tree
!
line console
 silent-time 0
!
line VTY
!
end
!

sh sys

Код:
System Description: Edge-Core FE L2 Switch ES3528M
System OID String: 1.3.6.1.4.1.259.6.10.94
System Information

sh ver

Код:
Hardware Version:        R01
 Chip Device ID:          Marvell 98DX106-B0, 88E6095[F]
 EPLD Version:            0.05
 Number of Ports:         28
 Main Power Status:       Up
 Redundant Power Status:  Not present

Agent (Master)
 Unit ID:                 1
 Loader Version:          1.0.4.1
 Boot ROM Version:        1.2.1.3
 Operation Code Version:  1.4.20.25

как решить ?

 83 
 : Июль 10, 2015, 09:05:09  
Автор spawn13 - Последний ответ от original
Чтобы получить:
Console#sh ip ig profile 3
IGMP Profile 3
  permit
  range 239.0.0.1 239.0.0.254
  range 239.0.1.1 239.0.1.255

Выполняем следующие snmp запросы:
1.Глобально включаем IGMP filter:
>>snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.6.10.94.1.9.17.0 i 1

2. Создаем профиль с ID=3
>>snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.6.10.94.1.9.18.1.3.3 i 1

3. Выбираем тип фильтрации deny(2)/permit(1)
>>snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.6.10.94.1.9.18.1.2.3 i 1

4.Выбор профиля с ID=3
>>snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.6.10.94.1.9.19.1.0 u 3

5. Указание типа профиля (поддерживается только IPv4(1).)
>>snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.6.10.94.1.9.19.2.0 i 1

6. Указываем начало диапазона:
>>snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.6.10.94.1.9.19.3.0 d 239.0.0.1

7. Указываем конец диапазона:
>>snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.6.10.94.1.9.19.4.0 d 239.0.0.254

8. Команда на создание диапазона (create(2)) для удаления диапазона используется destroy(3)
>>snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.6.10.94.1.9.19.5.0 i 2

9. Указываем начало диапазона:
>>snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.6.10.94.1.9.19.3.0 d 239.0.1.1

10. Указываем конец диапазона:
>>snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.6.10.94.1.9.19.4.0 d 239.0.1.255

11.Команда на создание:
>>snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.6.10.94.1.9.19.5.0 i 2

12. Привязка к порту($port) профиля ID=3:
>>snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.6.10.94.1.9.21.1.2.$port i 3

Не забываем сохранять конфигурацию после внесения изменений:

13. Выбираем источник копирования (running-config(2)):
snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.10.1.22.1.24.1.1.0 i 2

14. Выбираем место куда копировать (startup-config(3)):
snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.10.1.22.1.24.1.3.0 i 3

15. Выбираем имя файла в который будем копировать (string value)
snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.10.1.22.1.24.1.4.0 s 'startup1.cfg'

16. Запускаем процесс копирования(copy(2)):
snmpset -v 2c -c community Switch_IP 1.3.6.1.4.1.259.10.1.22.1.24.1.8.0 i 2

 84 
 : Июль 10, 2015, 08:06:49  
Автор spawn13 - Последний ответ от dominic
Подготовим и вышлем на почту.
Добрый день! Просьба выслать мне тоже

 85 
 : Июль 03, 2015, 09:10:22  
Автор DAnEq - Последний ответ от original
Возможные варианты результатов тестирования:

notTestedYet
ok
open
short
openShort
crosstalk
unknown
impedanceMismatch
fail
notSupport

Описание вариантов:
The result of cable diagnostics. If there is no fault
on the cable, the value is ok. Value notTestedYet
means the pair is not tested yet. Value ok means the
pair works well. Value open means there is a lack of
continuity between pins at each end of the pair. Value
short means conductors are short-circuited together on
the pair. Value openShort means the pair has open
and short issues. Value crosstalk means the pair is
incorrectly connected at one end. Value unknown means
pair has an error matching none of the above. Value
impedanceMismatch means different quality cables
connected together. Value fail means test failed.
Value notSupport means cable diagnostics is not
supported.

Значение в скобочках - расстояние до проблемного участка кабеля.
Наиболее популярные результаты это:
OK(0) - кабель в отличном состоянии и подключен в устройство
Open(xx) - кабель оборван на xx метре или не подключен в устройство
No Cable - кабель не подключен в порт коммутатора.
Short(xx) - пары накоротко замкнуты на xx метре.
impedanceMismatch(xx) - скрутка или плохой контакт на xx метре. Вода в кабеле или плохое качество кабеля.

 86 
 : Июль 02, 2015, 12:15:10  
Автор DAnEq - Последний ответ от DAnEq
а слона то я и не заметил :-) там бы ссылочку подправить ... спасибо, буду курить
еще вопрос - в этом аппарате есть новый от 3526 функционал по тестированию кабеля, а где почитать что значат ответы ?
не совсем понятно, чем отличается OK(0) OK(0) от Open(24) Open(24) ?
и что такое IMPED Error (27) ?
а вот на имеющемся ES3528M нашел Impedance mismatch (10) - что это такое ?

 87 
 : Июнь 30, 2015, 08:29:06  
Автор DAnEq - Последний ответ от original
Все MIB файлы для коммутаторов EdgeCore собраны на нашем FTP: ftp://ftp.romsat.ua/pub/Lan/Firmware%20Edge-Core/MIBs/

 88 
 : Июнь 26, 2015, 14:31:54  
Автор DAnEq - Последний ответ от DAnEq
Огромное спасибо. однако я перед постановкой вопроса поискал mib файл на ftp и до сих пор не могу его найти. может подскажете ссылку ?

 89 
 : Июнь 25, 2015, 11:05:39  
Автор DAnEq - Последний ответ от original
Snmp OID для каждой модели коммутаторов уникальны, кроме OID стандартных MIB таких как Q-BRIDGE-MIB, IF-MIB и пр.

Для ограничение скорости на порту с помощью Rate Limit следует использовать OID из следующей группы:
1.3.6.1.4.1.259.10.1.27.1.16.1.2.1

Для управления скоростью порта 10/100/1000 и его дуплексом следует использовать OID:
1.3.6.1.4.1.259.10.1.27.1.2.1.1.4
При этом отключая autonegotiation на порту используя OID:
1.3.6.1.4.1.259.10.1.27.1.2.1.1.7  

Более подробное описание возможных значений OID-ов Вы сможете найти в MIB файле который можно найти на нашем FTP.
Для сохранения конфигурации следует использовать набор OID в следующем порядке:
Snmpset 1.3.6.1.4.1.259.10.1.27.1.24.1.1.0 i 2    - выбор источника копирования(running-config)
Snmpset 1.3.6.1.4.1.259.10.1.27.1.24.1.2.0 s startup1.cfg             -              Исходное имя файла
Snmpset 1.3.6.1.4.1.259.10.1.27.1.24.1.3.0 i 3    – выбор назначения копирования(startup-config)
Snmpset 1.3.6.1.4.1.259.10.1.27.1.24.1.4.0 s startup1.cfg             –имя файла назначения
Snmpset 1.3.6.1.4.1.259.10.1.27.1.24.1.8.0 i 2    - команда на начало копирования.

Какой функционал multicast Вас интересует?

 90 
 : Июнь 24, 2015, 11:23:07  
Автор DAnEq - Последний ответ от DAnEq
порадовали оперативностью ответа. у нас сеть построеная на edge-core 3526xa-v2 купленых где то бу,но в силу их износа рассматриваем на что будем менять. вариант для замены ecs3510-28t
у нас нарезка скорости происходит на портах свичей, управление идет по протоколу снмп. поэтому нужны oid для snmp для выставления скорости на порту на ecs3510-28t. с 3526 не подходят, там скорость выставляется двумя параметрами которые помоему перемножаются а на этом одним параметром тупо в килобитах.
ну и oidы для мультикаста тоже нужны.
daneq(0)telenet.dn.ua,dandevadrakon(o)mail.ru буду признателен

Страниц: 1 ... 7 8 [9] 10