Romsat forum
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.

Войти
Romsat forum
Страниц: [1]
  Печать  
Автор Тема: ES3528M траблы с сохранением конфига по snmp  (Прочитано 3099 раз)
DAnEq
Newbie
*
Сообщений: 18


Просмотр профиля
« : Август 19, 2015, 12:31:18 »

Код:
snmpset -c BluewaterRd29200 -v 2c 192.168.222.37 .1.3.6.1.4.1.259.6.10.94.1.24.1.1 i 2
Error in packet.
Reason: notWritable (That object does not support modification)
Failed object: SNMPv2-SMI::enterprises.259.6.10.94.1.24.1.1

конфиг
Код:
#sh ru
building running-config, please wait...
!<stackingDB>00</stackingDB>

hostname sw-252

sntp server 10.10.20.1 0.0.0.0 0.0.0.0
!
clock timezone UTC hour 2 minute 0 after-utc
!
prompt Malibu
snmp-server location Malibu,CA,90264
!
clock timezone-predefined GMT+0200-Helsinki,Kyiv,Riga,Sofia,Tallinn,Vilnius
!
snmp-server community BirdviewAve7100 ro
snmp-server community BluewaterRd29200 rw
!
username admin access-level 15
username admin password 7 8ee662ce4ac345e5022119851a1af82b
username guest access-level 0
username guest password 7 084e0343a0486ff05530df6c705c8bb4
enable password level 15 7 8ee662ce4ac345e5022119851a1af82b
!
logging facility 22
logging host 192.168.222.1
!
vlan database
 vlan 1 name DefaultVlan media ethernet state active
 vlan 100 name mgmt media ethernet state active
 private-vlan 500 primary
!
spanning-tree mst configuration
!
ip dhcp snooping
ip dhcp snooping vlan 500
ip dhcp snooping information option
ip dhcp snooping information option remote-id ip-address encode hex
!
no lldp
!
interface vlan 1
 ip dhcp client class-id text 1
interface vlan 100
 ip address 192.168.222.37 255.255.255.0
interface vlan 500
!
interface ethernet 1/1
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/2
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/3
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/4
 no switchport broadcast
 rate-limit input 10240
 rate-limit output 6144
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/5
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/6
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/7
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/8
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/9
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/10
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/11
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/12
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/13
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/14
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/15
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/16
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/17
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/18
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/19
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/20
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/21
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/22
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/23
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/24
 shutdown
 no switchport broadcast
 rate-limit input 64
 rate-limit output 64
 ip source-guard sip-mac
 switchport mode private-vlan host
!
interface ethernet 1/25
 ip dhcp snooping trust
 switchport mode private-vlan promiscuous
 switchport allowed vlan add 100 tagged
!
interface ethernet 1/26
 ip dhcp snooping trust
 switchport mode private-vlan host
 switchport allowed vlan add 100 tagged
!
interface ethernet 1/27
!
interface ethernet 1/28
!
management telnet-client 10.10.20.1 10.10.20.15
management telnet-client 192.168.222.1 192.168.222.1
!
ip name-server 192.168.2.254
!
no spanning-tree
!
line console
 silent-time 0
!
line VTY
!
end
!

sh sys

Код:
System Description: Edge-Core FE L2 Switch ES3528M
System OID String: 1.3.6.1.4.1.259.6.10.94
System Information

sh ver

Код:
Hardware Version:        R01
 Chip Device ID:          Marvell 98DX106-B0, 88E6095[F]
 EPLD Version:            0.05
 Number of Ports:         28
 Main Power Status:       Up
 Redundant Power Status:  Not present

Agent (Master)
 Unit ID:                 1
 Loader Version:          1.0.4.1
 Boot ROM Version:        1.2.1.3
 Operation Code Version:  1.4.20.25

как решить ?
Записан
original
Administrator
Newbie
*****
Сообщений: 31



Просмотр профиля
« Ответ #1 : Август 20, 2015, 15:02:43 »

используйте полное значение OID как для src file type так и для остальных OID:
1.3.6.1.4.1.259.6.10.94.1.24.1.1.0

Для того чтобы правильно определить полный OID используйте snmpwalk:
# snmpwalk -v 2c -c public x.x.x.x 1.3.6.1.4.1.259.6.10.94.1.24.1
SNMPv2-SMI::enterprises.259.6.10.94.1.24.1.1.0 = INTEGER: 2
SNMPv2-SMI::enterprises.259.6.10.94.1.24.1.2.0 = ""
SNMPv2-SMI::enterprises.259.6.10.94.1.24.1.3.0 = INTEGER: 1
SNMPv2-SMI::enterprises.259.6.10.94.1.24.1.4.0 = STRING: "startup1.cfg"
SNMPv2-SMI::enterprises.259.6.10.94.1.24.1.5.0 = INTEGER: 2
SNMPv2-SMI::enterprises.259.6.10.94.1.24.1.6.0 = IpAddress: 0.0.0.0
SNMPv2-SMI::enterprises.259.6.10.94.1.24.1.7.0 = INTEGER: 1
SNMPv2-SMI::enterprises.259.6.10.94.1.24.1.8.0 = INTEGER: 1
SNMPv2-SMI::enterprises.259.6.10.94.1.24.1.9.0 = INTEGER: 30
SNMPv2-SMI::enterprises.259.6.10.94.1.24.1.12.0 = ""
SNMPv2-SMI::enterprises.259.6.10.94.1.24.1.13.0 = ""
Записан
Страниц: [1]
  Печать  
 
Перейти в: